Write a C++ program which prints three highest numbers from a list of numbers in descending order

  • برمجة سي بلس بلس
  • برمجة

Write a C++ program which prints three highest numbers from a list of numbers in descending order

Sample Output:

Sample input : 2 5 3 7 29 1
Sample Output: 
29
7
5

الأجوبة

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main() {
    vector<int> nums;
    int n;
    while (cin >> n) {
        nums.push_back(n);
    }
    sort(nums.rbegin(), nums.rend());

    for (int i = 0; i != 3; ++i) {
        cout << nums[i] << endl;
    }
    return 0;
}
هل كان المحتوى مفيد؟

تبحث عن مدرس اونلاين؟

محتاج مساعدة باختيار المدرس الافضل؟ تواصل مع فريقنا الان لمساعدتك بتأمين افضل مدرس
ماهو التخصص الذي تبحث عنه؟
اكتب هنا...